{"action":"Upgrade org.apache.geode:geode-core to 1.10.0 or later.","affected":[{"fixed":"1.10.0","introduced":"0"}],"component":"org.apache.geode:geode-core","cve_ids":["CVE-2019-10091"],"ecosystem":"Maven","epss":0.01417,"exploited":false,"fixed_versions":["1.10.0"],"ghsa_id":"GHSA-wc4x-4gm2-74j8","id":"tcs_01M5N9G2PRA2S6QW7NK6B5FE3D","modified_at":"2024-02-16T08:11:37.987139Z","published_at":"2022-02-10T20:51:04Z","references":["https://osv.dev/vulnerability/GHSA-wc4x-4gm2-74j8","https://nvd.nist.gov/vuln/detail/CVE-2019-10091","https://github.com/apache/geode/pull/3849","https://github.com/apache/geode/commit/e57028fd62a2f5980ea6c9a7ab89ada06c828634","https://cwiki.apache.org/confluence/display/GEODE/Release+Notes#ReleaseNotes-SecurityVulnerabilities","https://issues.apache.org/jira/browse/GEODE-7018","https://lists.apache.org/thread.html/r3342077ac4798631300366be86e545d0c08753cca8fd2663867fe200%40%3Cdev.geode.apache.org%3E"],"severity":{"label":"high","score":7.4},"sources":[{"source":"osv","source_id":"GHSA-wc4x-4gm2-74j8","url":"https://osv.dev/vulnerability/GHSA-wc4x-4gm2-74j8"}],"summary":"Apache Geode SSL endpoint verification vulnerability"}