{"action":"Upgrade struts:struts to 1.2.9-162.31.1 or later.","affected":[{"fixed":"1.2.9-162.31.1","introduced":"0"}],"component":"struts:struts","cve_ids":["CVE-2008-2025"],"ecosystem":"Maven","epss":0.07911,"exploited":false,"fixed_versions":["1.2.9-162.31.1"],"ghsa_id":"GHSA-wcgx-2hvx-5cwr","id":"tcs_01M5N9G4H9XT009VJJE3THRQQJ","modified_at":"2024-12-05T05:35:08.394103Z","published_at":"2022-05-01T23:46:00Z","references":["https://osv.dev/vulnerability/GHSA-wcgx-2hvx-5cwr","https://nvd.nist.gov/vuln/detail/CVE-2008-2025","https://bugzilla.novell.com/show_bug.cgi?id=385273","https://github.com/apache/struts","https://launchpad.net/bugs/cve/2008-2025","https://web.archive.org/web/20090410082732/http://secunia.com/advisories/34642","https://web.archive.org/web/20090411051126/http://secunia.com/advisories/34567","http://download.opensuse.org/update/10.3-test/repodata/patch-struts-5872.xml","http://lists.opensuse.org/opensuse-security-announce/2009-04/msg00003.html","http://support.novell.com/security/cve/CVE-2008-2025.html"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-wcgx-2hvx-5cwr","url":"https://osv.dev/vulnerability/GHSA-wcgx-2hvx-5cwr"}],"summary":"Apache Struts Cross-site Scripting vulnerability"}