{"action":"Upgrade pango1.0 to 1.26.2-1 or later.","affected":[{"fixed":"1.26.2-1","introduced":"0"}],"component":"pango1.0","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.26.2-1"],"id":"tcs_01M5N9G7ATQR7WGZKD19P2MDGP","modified_at":"2026-10-23T17:47:48.118199189Z","published_at":"2010-03-18T17:30:00.463Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2010-0421","https://security-tracker.debian.org/tracker/CVE-2010-0421"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2010-0421#Debian:14/pango1.0","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2010-0421"}],"summary":"Array index error in the hb_ot_layout_build_glyph_classes function in pango/opentype/hb-ot-layout.cc in Pango before 1.27.1 allows context-dependent attackers to cause a denial of service (application"}