{"action":"Upgrade perl to 5.10.1-13 or later.","affected":[{"fixed":"5.10.1-13","introduced":"0"}],"component":"perl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["5.10.1-13"],"id":"tcs_01M5N9GZBXE3S55WF2SES702KN","modified_at":"2026-10-23T17:47:25.905438967Z","published_at":"2010-06-21T16:30:01.133Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2010-1168","https://security-tracker.debian.org/tracker/CVE-2010-1168"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2010-1168#Debian:13/perl","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2010-1168"}],"summary":"The Safe (aka Safe.pm) module before 2.25 for Perl allows context-dependent attackers to bypass intended (1) Safe::reval and (2) Safe::rdo access restrictions, and inject and execute arbitrary code, v"}