{"action":"Upgrade jruby to 1.5.0~rc1-1 or later.","affected":[{"fixed":"1.5.0~rc1-1","introduced":"0"}],"component":"jruby","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["1.5.0~rc1-1"],"id":"tcs_01M5N9H7DK87T4KBDFYVW4SWKE","modified_at":"2026-10-23T17:47:49.561346123Z","published_at":"2012-11-23T19:55:01.273Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2010-1330","https://security-tracker.debian.org/tracker/CVE-2010-1330"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2010-1330#Debian:13/jruby","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2010-1330"}],"summary":"The regular expression engine in JRuby before 1.4.1, when $KCODE is set to 'u', does not properly handle characters immediately after a UTF-8 character, which allows remote attackers to conduct cross-"}