{"action":"Upgrade org.apache.axis2:axis2-transport-http to 1.8.0 or later.","affected":[{"fixed":"1.8.0","introduced":"0"}],"component":"org.apache.axis2:axis2-transport-http","cve_ids":["CVE-2012-5785"],"ecosystem":"Maven","epss":0.02225,"exploited":false,"fixed_versions":["1.8.0"],"ghsa_id":"GHSA-wwq7-pxwc-p4rc","id":"tcs_01M5N9HB2ZNNEWQDJGC21V0H3E","modified_at":"2025-12-04T22:41:45.024009Z","published_at":"2022-05-17T01:38:56Z","references":["https://osv.dev/vulnerability/GHSA-wwq7-pxwc-p4rc","https://nvd.nist.gov/vuln/detail/CVE-2012-5785","https://exchange.xforce.ibmcloud.com/vulnerabilities/79830","https://github.com/apache/axis-axis2-java-core","https://issues.apache.org/jira/browse/AXIS2-6018","http://www.cs.utexas.edu/~shmat/shmat_ccs12.pdf"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-wwq7-pxwc-p4rc#Maven/org.apache.axis2:axis2-transport-http","url":"https://osv.dev/vulnerability/GHSA-wwq7-pxwc-p4rc"}],"summary":"Apache Axis2 has Improper Input Validation"}