{"action":"Upgrade org.apache.struts:struts2-rest-plugin to 2.5.16 or later.","affected":[{"fixed":"2.5.16","introduced":"2.5.0"}],"component":"org.apache.struts:struts2-rest-plugin","cve_ids":["CVE-2017-15707"],"ecosystem":"Maven","epss":0.04889,"exploited":false,"fixed_versions":["2.5.16"],"ghsa_id":"GHSA-xcrm-qpp8-hcw4","id":"tcs_01M5N9J5JDRP91H19PQW5V8419","modified_at":"2024-02-17T05:28:31.799954Z","published_at":"2018-10-16T19:35:55Z","references":["https://osv.dev/vulnerability/GHSA-xcrm-qpp8-hcw4","https://nvd.nist.gov/vuln/detail/CVE-2017-15707","https://cwiki.apache.org/confluence/display/WW/S2-054","https://github.com/advisories/GHSA-xcrm-qpp8-hcw4","https://security.netapp.com/advisory/ntap-20171214-0001","http://www.oracle.com/technetwork/security-advisory/cpuapr2018-3678067.html","http://www.oracle.com/technetwork/security-advisory/cpujul2018-4258247.html","http://www.securityfocus.com/bid/102021","http://www.securitytracker.com/id/1039946"],"severity":{"label":"medium","score":6.2},"sources":[{"source":"osv","source_id":"GHSA-xcrm-qpp8-hcw4","url":"https://osv.dev/vulnerability/GHSA-xcrm-qpp8-hcw4"}],"summary":"Moderate severity vulnerability that affects org.apache.struts:struts2-rest-plugin"}