{"action":"Upgrade freeciv to 2.2.1-1 or later.","affected":[{"fixed":"2.2.1-1","introduced":"0"}],"component":"freeciv","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.2.1-1"],"id":"tcs_01M5N9JFY88760EWPHKXAVMBBN","modified_at":"2026-10-23T17:47:23.404242525Z","published_at":"2010-07-08T12:54:47.130Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2010-2445","https://security-tracker.debian.org/tracker/CVE-2010-2445"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2010-2445#Debian:14/freeciv","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2010-2445"}],"summary":"freeciv 2.2 before 2.2.1 and 2.3 before 2.3.0 allows attackers to read arbitrary files or execute arbitrary commands via a scenario that contains Lua functionality, related to the (1) os, (2) io, (3)"}