{"action":"Upgrade mapserver to 5.6.4-1 or later.","affected":[{"fixed":"5.6.4-1","introduced":"0"}],"component":"mapserver","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["5.6.4-1"],"id":"tcs_01M5N9JWRFPVJP66PMYTJAPFM3","modified_at":"2026-10-23T17:47:37.441513391Z","published_at":"2010-08-02T22:00:01.297Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2010-2540","https://security-tracker.debian.org/tracker/CVE-2010-2540"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2010-2540","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2010-2540"}],"summary":"mapserv.c in mapserv in MapServer before 4.10.6 and 5.x before 5.6.4 does not properly restrict the use of CGI command-line arguments that were intended for debugging, which allows remote attackers to"}