{"action":"Upgrade org.jenkins-ci.plugins:htmlpublisher to 1.32.1 or later.","affected":[{"fixed":"1.32.1","introduced":"0"}],"component":"org.jenkins-ci.plugins:htmlpublisher","cve_ids":["CVE-2024-28150"],"ecosystem":"Maven","epss":0.00681,"exploited":false,"fixed_versions":["1.32.1"],"ghsa_id":"GHSA-xrrw-9j78-hpf3","id":"tcs_01M5N9JYFN9TGJPA03V24V96C0","modified_at":"2024-11-22T22:36:11.323368Z","published_at":"2024-03-06T18:30:38Z","references":["https://osv.dev/vulnerability/GHSA-xrrw-9j78-hpf3","https://nvd.nist.gov/vuln/detail/CVE-2024-28150","https://github.com/jenkinsci/htmlpublisher-plugin/commit/c0eed940e65ea90f9b5ba21aa3d953546d5cd8ad","https://github.com/jenkinsci/htmlpublisher-plugin","https://www.jenkins.io/security/advisory/2024-03-06/#SECURITY-3302","http://www.openwall.com/lists/oss-security/2024/03/06/3"],"severity":{"label":"high","score":8},"sources":[{"source":"osv","source_id":"GHSA-xrrw-9j78-hpf3","url":"https://osv.dev/vulnerability/GHSA-xrrw-9j78-hpf3"}],"summary":"Jenkins HTML Publisher Plugin Stored XSS vulnerability"}