{"action":"Upgrade org.apache.activemq:activemq-mqtt to 6.2.4 or later.","affected":[{"fixed":"6.2.4","introduced":"6.0.0"}],"component":"org.apache.activemq:activemq-mqtt","cve_ids":["CVE-2026-40046"],"ecosystem":"Maven","epss":0.00375,"exploited":false,"fixed_versions":["6.2.4"],"ghsa_id":"GHSA-xvqc-pp94-fmpx","id":"tcs_01M5N9K1KJTM4FZBBSHSKVR6ZG","modified_at":"2026-04-13T08:27:19.495842350Z","published_at":"2026-04-09T18:31:27Z","references":["https://osv.dev/vulnerability/GHSA-xvqc-pp94-fmpx","https://nvd.nist.gov/vuln/detail/CVE-2026-40046","https://activemq.apache.org/security-advisories.data/CVE-2026-40046-announcement.txt","https://lists.apache.org/thread/zdntj5rcgjjzrpow84o339lzldy68zrg","https://www.cve.org/CVERecord?id=CVE-2025-66168"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-xvqc-pp94-fmpx#Maven/org.apache.activemq:activemq-mqtt","url":"https://osv.dev/vulnerability/GHSA-xvqc-pp94-fmpx"}],"summary":"Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ MQTT vulnerable to Integer Overflow or Wraparound"}