{"action":"Upgrade evince to 2.30.3-2 or later.","affected":[{"fixed":"2.30.3-2","introduced":"0"}],"component":"evince","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.30.3-2"],"id":"tcs_01M5N9K338V3C382TV9GSCRVVP","modified_at":"2026-10-23T17:47:38.232299071Z","published_at":"2011-01-07T19:00:17.203Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2010-2640","https://security-tracker.debian.org/tracker/CVE-2010-2640"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2010-2640","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2010-2640"}],"summary":"Array index error in the PK font parser in the dvi-backend component in Evince 2.32 and earlier allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary c"}