{"action":"Upgrade cups to 1.4.4-7 or later.","affected":[{"fixed":"1.4.4-7","introduced":"0"}],"component":"cups","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.4.4-7"],"id":"tcs_01M5N9KFJXSP2VKSHFHKC8YYQ7","modified_at":"2026-10-23T18:02:42.938975248Z","published_at":"2010-11-05T17:00:01.843Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2010-2941","https://security-tracker.debian.org/tracker/CVE-2010-2941"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2010-2941#Debian:14/cups","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2010-2941"}],"summary":"ipp.c in cupsd in CUPS 1.4.4 and earlier does not properly allocate memory for attribute values with invalid string data types, which allows remote attackers to cause a denial of service (use-after-fr"}