{"action":"Upgrade libhx to 3.5-2 or later.","affected":[{"fixed":"3.5-2","introduced":"0"}],"component":"libhx","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.5-2"],"id":"tcs_01M5N9KGC3R9H3RCX5ZAQ0ACJX","modified_at":"2026-10-23T17:47:38.057351164Z","published_at":"2010-08-24T20:00:00.910Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2010-2947","https://security-tracker.debian.org/tracker/CVE-2010-2947"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2010-2947#Debian:14/libhx","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2010-2947"}],"summary":"Heap-based buffer overflow in the HX_split function in string.c in libHX before 3.6 allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via a string that"}