{"action":"Upgrade pam to 1.1.2-1 or later.","affected":[{"fixed":"1.1.2-1","introduced":"0"}],"component":"pam","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.1.2-1"],"id":"tcs_01M5N9KX851RSWJBV471CCVBDK","modified_at":"2026-10-23T17:47:39.698435559Z","published_at":"2011-01-24T18:00:01.847Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2010-3316","https://security-tracker.debian.org/tracker/CVE-2010-3316"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2010-3316","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2010-3316"}],"summary":"The run_coprocess function in pam_xauth.c in the pam_xauth module in Linux-PAM (aka pam) before 1.1.2 does not check the return values of the setuid, setgid, and setgroups system calls, which might al"}