{"action":"Upgrade putty to 0.68-r0 or later.","affected":[{"fixed":"0.68-r0","introduced":"0"}],"component":"putty","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.5","exploited":false,"fixed_versions":["0.68-r0"],"id":"tcs_01M5N9MHC2V802M5R9CR2CV78N","modified_at":"2026-06-15T18:24:51.925313761Z","published_at":"2017-03-27T17:59:00.850Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2017-6542","https://security.alpinelinux.org/vuln/CVE-2017-6542"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2017-6542#Alpine:v3.5/putty","url":"https://osv.dev/vulnerability/ALPINE-CVE-2017-6542"}],"summary":"The ssh_agent_channel_data function in PuTTY before 0.68 allows remote attackers to have unspecified impact via a large length value in an agent protocol message and leveraging the ability to connect"}