{"action":"Upgrade glibc to 2.11.2-8 or later.","affected":[{"fixed":"2.11.2-8","introduced":"0"}],"component":"glibc","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.11.2-8"],"id":"tcs_01M5N9MPRJTC20ZFRNSVHS2X4Y","modified_at":"2026-10-23T17:47:49.516124437Z","published_at":"2011-01-07T19:00:17.843Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2010-3856","https://security-tracker.debian.org/tracker/CVE-2010-3856"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2010-3856#Debian:13/glibc","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2010-3856"}],"summary":"ld.so in the GNU C Library (aka glibc or libc6) before 2.11.3, and 2.12.x before 2.12.2, does not properly restrict use of the LD_AUDIT environment variable to reference dynamic shared objects (DSOs)"}