{"action":"Upgrade openconnect to 2.25-0.1 or later.","affected":[{"fixed":"2.25-0.1","introduced":"0"}],"component":"openconnect","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.25-0.1"],"id":"tcs_01M5N9MS090ZFQXG08MCQXN046","modified_at":"2026-10-23T17:47:40.131193155Z","published_at":"2010-10-14T05:58:42.893Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2010-3901","https://security-tracker.debian.org/tracker/CVE-2010-3901"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2010-3901#Debian:13/openconnect","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2010-3901"}],"summary":"OpenConnect before 2.25 does not properly validate X.509 certificates, which allows man-in-the-middle attackers to spoof arbitrary AnyConnect SSL VPN servers via a crafted server certificate that (1)"}