{"action":"Upgrade glibc to 2.19-4 or later.","affected":[{"fixed":"2.19-4","introduced":"0"}],"component":"glibc","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.19-4"],"id":"tcs_01M5N9MXZ9340FPV2GCE9WCF6W","modified_at":"2026-10-23T17:47:33.223284415Z","published_at":"2011-01-13T19:00:02.900Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2010-4051","https://security-tracker.debian.org/tracker/CVE-2010-4051"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2010-4051#Debian:13/glibc","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2010-4051"}],"summary":"The regcomp implementation in the GNU C Library (aka glibc or libc6) through 2.11.3, and 2.12.x through 2.12.2, allows context-dependent attackers to cause a denial of service (application crash) via"}