{"action":"Upgrade openssl to 0.9.8o-4 or later.","affected":[{"fixed":"0.9.8o-4","introduced":"0"}],"component":"openssl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["0.9.8o-4"],"id":"tcs_01M5N9N2538D86X78RRF5MV6DM","modified_at":"2026-10-23T17:47:40.566488665Z","published_at":"2010-12-06T21:05:48.687Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2010-4180","https://security-tracker.debian.org/tracker/CVE-2010-4180"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2010-4180#Debian:13/openssl","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2010-4180"}],"summary":"OpenSSL before 0.9.8q, and 1.0.x before 1.0.0c, when SSL_OP_NETSCAPE_REUSE_CIPHER_CHANGE_BUG is enabled, does not properly prevent modification of the ciphersuite in the session cache, which allows re"}