{"action":"Upgrade exim4 to 4.70-1 or later.","affected":[{"fixed":"4.70-1","introduced":"0"}],"component":"exim4","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["4.70-1"],"id":"tcs_01M5N9NABAWWB64TR37YWEHTH3","modified_at":"2026-10-23T18:02:43.508296144Z","published_at":"2010-12-14T16:00:04.163Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2010-4344","https://security-tracker.debian.org/tracker/CVE-2010-4344"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2010-4344","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2010-4344"}],"summary":"Heap-based buffer overflow in the string_vformat function in string.c in Exim before 4.70 allows remote attackers to execute arbitrary code via an SMTP session that includes two MAIL commands in conju"}