{"action":"Upgrade rails to 2.3.11-0.1 or later.","affected":[{"fixed":"2.3.11-0.1","introduced":"0"}],"component":"rails","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.3.11-0.1"],"id":"tcs_01M5N9PXPZP0N57TM8RFV7HZ4M","modified_at":"2026-10-23T17:47:33.617467761Z","published_at":"2011-02-14T21:00:03.007Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2011-0446","https://security-tracker.debian.org/tracker/CVE-2011-0446"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2011-0446#Debian:14/rails","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2011-0446"}],"summary":"Multiple cross-site scripting (XSS) vulnerabilities in the mail_to helper in Ruby on Rails before 2.3.11, and 3.x before 3.0.4, when javascript encoding is used, allow remote attackers to inject arbit"}