{"action":"Upgrade rails to 2.3.11-0.1 or later.","affected":[{"fixed":"2.3.11-0.1","introduced":"0"}],"component":"rails","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.3.11-0.1"],"id":"tcs_01M5N9PY75S2ZVS2S63DENSRZC","modified_at":"2026-10-23T17:47:42.494015881Z","published_at":"2011-02-14T21:00:03.087Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2011-0447","https://security-tracker.debian.org/tracker/CVE-2011-0447"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2011-0447","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2011-0447"}],"summary":"Ruby on Rails 2.1.x, 2.2.x, and 2.3.x before 2.3.11, and 3.x before 3.0.4, does not properly validate HTTP requests that contain an X-Requested-With header, which makes it easier for remote attackers"}