{"action":"Upgrade samba to 2:3.5.10~dfsg-1 or later.","affected":[{"fixed":"2:3.5.10~dfsg-1","introduced":"0"}],"component":"samba","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2:3.5.10~dfsg-1"],"id":"tcs_01M5N9T49P9BYH0DGTRSMAN7S0","modified_at":"2026-10-23T17:47:27.335626893Z","published_at":"2011-07-29T20:55:02.220Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2011-2694","https://security-tracker.debian.org/tracker/CVE-2011-2694"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2011-2694#Debian:14/samba","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2011-2694"}],"summary":"Cross-site scripting (XSS) vulnerability in the chg_passwd function in web/swat.c in the Samba Web Administration Tool (SWAT) in Samba 3.x before 3.5.10 allows remote authenticated administrators to i"}