{"action":"Upgrade rails to 2.3.14 or later.","affected":[{"fixed":"2.3.14","introduced":"0"}],"component":"rails","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.3.14"],"id":"tcs_01M5N9TRCRA4D0NBTG13W83QED","modified_at":"2026-10-23T17:47:25.612973934Z","published_at":"2011-08-29T18:55:01.503Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2011-2931","https://security-tracker.debian.org/tracker/CVE-2011-2931"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2011-2931#Debian:13/rails","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2011-2931"}],"summary":"Cross-site scripting (XSS) vulnerability in the strip_tags helper in actionpack/lib/action_controller/vendor/html-scanner/html/node.rb in Ruby on Rails before 2.3.13, 3.0.x before 3.0.10, and 3.1.x be"}