{"action":"Upgrade rails to 2.3.14 or later.","affected":[{"fixed":"2.3.14","introduced":"0"}],"component":"rails","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.3.14"],"id":"tcs_01M5N9TRSS3PQYTQV647NKQR4X","modified_at":"2026-10-23T17:47:23.151347837Z","published_at":"2011-08-29T18:55:01.567Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2011-2932","https://security-tracker.debian.org/tracker/CVE-2011-2932"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2011-2932#Debian:13/rails","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2011-2932"}],"summary":"Cross-site scripting (XSS) vulnerability in activesupport/lib/active_support/core_ext/string/output_safety.rb in Ruby on Rails 2.x before 2.3.13, 3.0.x before 3.0.10, and 3.1.x before 3.1.0.rc5 allows"}