{"action":"Upgrade libencode-perl to 2.44-1 or later.","affected":[{"fixed":"2.44-1","introduced":"0"}],"component":"libencode-perl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.44-1"],"id":"tcs_01M5N9TSPFDX5R23C3G991DV8P","modified_at":"2026-10-23T17:47:39.189068412Z","published_at":"2012-01-13T18:55:02.987Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2011-2939","https://security-tracker.debian.org/tracker/CVE-2011-2939"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2011-2939#Debian:13/libencode-perl","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2011-2939"}],"summary":"Off-by-one error in the decode_xs function in Unicode/Unicode.xs in the Encode module before 2.44, as used in Perl before 5.15.6, might allow context-dependent attackers to cause a denial of service ("}