{"action":"Upgrade perl to 5.12.4-4 or later.","affected":[{"fixed":"5.12.4-4","introduced":"0"}],"component":"perl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["5.12.4-4"],"id":"tcs_01M5N9TT0THQAW35J5HC05RH0K","modified_at":"2026-10-23T17:47:39.189068412Z","published_at":"2012-01-13T18:55:02.987Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2011-2939","https://security-tracker.debian.org/tracker/CVE-2011-2939"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2011-2939#Debian:12/perl","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2011-2939"}],"summary":"Off-by-one error in the decode_xs function in Unicode/Unicode.xs in the Encode module before 2.44, as used in Perl before 5.15.6, might allow context-dependent attackers to cause a denial of service ("}