{"action":"Upgrade rails to 2.3.14 or later.","affected":[{"fixed":"2.3.14","introduced":"0"}],"component":"rails","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.3.14"],"id":"tcs_01M5N9V4W06WXD9TF04JQMHPCC","modified_at":"2026-10-23T17:47:37.993951526Z","published_at":"2011-08-29T18:55:01.643Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2011-3186","https://security-tracker.debian.org/tracker/CVE-2011-3186"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2011-3186#Debian:14/rails","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2011-3186"}],"summary":"CRLF injection vulnerability in actionpack/lib/action_controller/response.rb in Ruby on Rails 2.3.x before 2.3.13 allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response spl"}