{"action":"Upgrade xen to 4.6.3-r9 or later.","affected":[{"fixed":"4.6.3-r9","introduced":"0"}],"component":"xen","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.4","exploited":false,"fixed_versions":["4.6.3-r9"],"id":"tcs_01M5N9V50BR1VADP92CMHFM68H","modified_at":"2026-06-15T18:18:07.083576159Z","published_at":"2017-05-11T19:29:00.273Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2017-8904","https://security.alpinelinux.org/vuln/CVE-2017-8904"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2017-8904#Alpine:v3.4/xen","url":"https://osv.dev/vulnerability/ALPINE-CVE-2017-8904"}],"summary":"Xen through 4.8.x mishandles the \"contains segment descriptors\" property during GNTTABOP_transfer (aka guest transfer) operations, which might allow PV guest OS users to execute arbitrary code on the"}