{"action":"Upgrade php5 to 5.6.31-r0 or later.","affected":[{"fixed":"5.6.31-r0","introduced":"0"}],"component":"php5","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.4","exploited":false,"fixed_versions":["5.6.31-r0"],"id":"tcs_01M5N9VHMAC471FFC6T5XD2VDY","modified_at":"2026-06-15T18:25:25.069315230Z","published_at":"2017-05-24T15:29:00.370Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2017-9228","https://security.alpinelinux.org/vuln/CVE-2017-9228"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2017-9228","url":"https://osv.dev/vulnerability/ALPINE-CVE-2017-9228"}],"summary":"An issue was discovered in Oniguruma 6.2.0, as used in Oniguruma-mod in Ruby through 2.4.1 and mbstring in PHP through 7.1.5. A heap out-of-bounds write occurs in bitset_set_range() during regular exp"}