{"action":"Upgrade php5 to 5.6.31-r0 or later.","affected":[{"fixed":"5.6.31-r0","introduced":"0"}],"component":"php5","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.5","exploited":false,"fixed_versions":["5.6.31-r0"],"id":"tcs_01M5N9VJ7SAQRF7WBS8CXN115Y","modified_at":"2026-06-15T18:25:11.995432181Z","published_at":"2017-05-24T15:29:00.417Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2017-9229","https://security.alpinelinux.org/vuln/CVE-2017-9229"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2017-9229#Alpine:v3.5/php5","url":"https://osv.dev/vulnerability/ALPINE-CVE-2017-9229"}],"summary":"An issue was discovered in Oniguruma 6.2.0, as used in Oniguruma-mod in Ruby through 2.4.1 and mbstring in PHP through 7.1.5. A SIGSEGV occurs in left_adjust_char_head() during regular expression comp"}