{"action":"Upgrade apache2 to 2.2.21-4 or later.","affected":[{"fixed":"2.2.21-4","introduced":"0"}],"component":"apache2","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.2.21-4"],"id":"tcs_01M5N9VTWKJZT3ZFVW2AKCVVT0","modified_at":"2026-10-23T17:47:46.025271685Z","published_at":"2011-11-08T11:55:05.693Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2011-3607","https://security-tracker.debian.org/tracker/CVE-2011-3607"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2011-3607","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2011-3607"}],"summary":"Integer overflow in the ap_pregsub function in server/util.c in the Apache HTTP Server 2.0.x through 2.0.64 and 2.2.x through 2.2.21, when the mod_setenvif module is enabled, allows local users to gai"}