{"action":"Upgrade puppet to 2.7.3-2 or later.","affected":[{"fixed":"2.7.3-2","introduced":"0"}],"component":"puppet","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:11","exploited":false,"fixed_versions":["2.7.3-2"],"id":"tcs_01M5N9W0VPR72FVY8K52V60JXR","modified_at":"2026-08-25T02:47:22.396950769Z","published_at":"2011-10-27T20:55:01.230Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2011-3848","https://security-tracker.debian.org/tracker/CVE-2011-3848"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2011-3848","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2011-3848"}],"summary":"Directory traversal vulnerability in Puppet 2.6.x before 2.6.10 and 2.7.x before 2.7.4 allows remote attackers to write X.509 Certificate Signing Request (CSR) to arbitrary locations via (1) a double-"}