{"action":"Upgrade puppet to 2.7.3-3 or later.","affected":[{"fixed":"2.7.3-3","introduced":"0"}],"component":"puppet","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:11","exploited":false,"fixed_versions":["2.7.3-3"],"id":"tcs_01M5N9W0ZY3GVAPK47YP5FHTG1","modified_at":"2026-08-25T02:47:37.768206447Z","published_at":"2011-10-27T20:55:01.417Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2011-3869","https://security-tracker.debian.org/tracker/CVE-2011-3869"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2011-3869","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2011-3869"}],"summary":"Puppet 2.7.x before 2.7.5, 2.6.x before 2.6.11, and 0.25.x allows local users to overwrite arbitrary files via a symlink attack on the .k5login file."}