{"action":"Upgrade nginx to 1.1.8-1 or later.","affected":[{"fixed":"1.1.8-1","introduced":"0"}],"component":"nginx","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.1.8-1"],"id":"tcs_01M5N9WVAT4WFG3VKEE1PZJB5M","modified_at":"2026-10-23T17:47:30.136564396Z","published_at":"2011-12-08T20:55:01Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2011-4315","https://security-tracker.debian.org/tracker/CVE-2011-4315"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2011-4315","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2011-4315"}],"summary":"Heap-based buffer overflow in compression-pointer processing in core/ngx_resolver.c in nginx before 1.0.10 allows remote resolvers to cause a denial of service (daemon crash) or possibly have unspecif"}