{"action":"Upgrade jruby to 1.5.6-4 or later.","affected":[{"fixed":"1.5.6-4","introduced":"0"}],"component":"jruby","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["1.5.6-4"],"id":"tcs_01M5N9XJCQ9AAPDKVNV6H8P55C","modified_at":"2026-10-23T17:47:36.860544586Z","published_at":"2011-12-30T01:55:01.500Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2011-4838","https://security-tracker.debian.org/tracker/CVE-2011-4838"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2011-4838#Debian:13/jruby","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2011-4838"}],"summary":"JRuby before 1.6.5.1 computes hash values without restricting the ability to trigger hash collisions predictably, which allows context-dependent attackers to cause a denial of service (CPU consumption"}