{"action":"Upgrade xapian-core to 1.4.6-r0 or later.","affected":[{"fixed":"1.4.6-r0","introduced":"0"}],"component":"xapian-core","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.24","exploited":false,"fixed_versions":["1.4.6-r0"],"id":"tcs_01M5N9XVNBDVZ1KVM398TJV0VG","modified_at":"2026-10-23T17:17:55.144361510Z","published_at":"2018-07-02T12:29:00.220Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2018-0499","https://security.alpinelinux.org/vuln/CVE-2018-0499"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2018-0499#Alpine:v3.24/xapian-core","url":"https://osv.dev/vulnerability/ALPINE-CVE-2018-0499"}],"summary":"A cross-site scripting vulnerability in queryparser/termgenerator_internal.cc in Xapian xapian-core before 1.4.6 exists due to incomplete HTML escaping by Xapian::MSet::snippet()."}