{"action":"Upgrade apt to 0.7.25 or later.","affected":[{"fixed":"0.7.25","introduced":"0"}],"component":"apt","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["0.7.25"],"id":"tcs_01M5N9ZGC1TMYC29CMV51VJ162","modified_at":"2026-10-23T17:47:41.610798963Z","published_at":"2012-06-19T20:55:05.380Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2012-0954","https://security-tracker.debian.org/tracker/CVE-2012-0954"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2012-0954#Debian:13/apt","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2012-0954"}],"summary":"APT 0.7.x before 0.7.25 and 0.8.x before 0.8.16, when using the apt-key net-update to import keyrings, relies on GnuPG argument order and does not check GPG subkeys, which might allow remote attackers"}