{"action":"Upgrade rails to 2.3.14 or later.","affected":[{"fixed":"2.3.14","introduced":"0"}],"component":"rails","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.3.14"],"id":"tcs_01M5N9ZMZHA6104Q0CDRHWEXD7","modified_at":"2026-10-23T17:47:33.797512420Z","published_at":"2012-03-13T10:55:01.213Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2012-1098","https://security-tracker.debian.org/tracker/CVE-2012-1098"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2012-1098#Debian:13/rails","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2012-1098"}],"summary":"Cross-site scripting (XSS) vulnerability in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote attackers to inject arbitrary web script or HTML via vectors inv"}