{"action":"Upgrade puppet to 2.7.13-1 or later.","affected":[{"fixed":"2.7.13-1","introduced":"0"}],"component":"puppet","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:11","exploited":false,"fixed_versions":["2.7.13-1"],"id":"tcs_01M5NA0QPQ7HC4PW9Y8Y4YKV0X","modified_at":"2026-08-19T06:47:40.131215228Z","published_at":"2012-05-29T20:55:07.213Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2012-1906","https://security-tracker.debian.org/tracker/CVE-2012-1906"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2012-1906","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2012-1906"}],"summary":"Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 uses predictable file names when installing Mac OS X packages from a"}