{"action":"Upgrade puppet to 2.7.13-1 or later.","affected":[{"fixed":"2.7.13-1","introduced":"0"}],"component":"puppet","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:11","exploited":false,"fixed_versions":["2.7.13-1"],"id":"tcs_01M5NA0R5QR81YY41YHMDVDCPC","modified_at":"2026-08-19T06:47:34.061201207Z","published_at":"2012-05-29T20:55:08.243Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2012-1988","https://security-tracker.debian.org/tracker/CVE-2012-1988"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2012-1988","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2012-1988"}],"summary":"Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 allows remote authenticated users with agent SSL keys and file-creat"}