{"action":"Upgrade puppet to 2.7.13-1 or later.","affected":[{"fixed":"2.7.13-1","introduced":"0"}],"component":"puppet","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:11","exploited":false,"fixed_versions":["2.7.13-1"],"id":"tcs_01M5NA0R8WRMJT1ZTVGTQFWW2N","modified_at":"2026-08-19T06:47:24.473625933Z","published_at":"2012-06-27T18:55:01.430Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2012-1989","https://security-tracker.debian.org/tracker/CVE-2012-1989"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2012-1989","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2012-1989"}],"summary":"telnet.rb in Puppet 2.7.x before 2.7.13 and Puppet Enterprise (PE) 1.2.x, 2.0.x, and 2.5.x before 2.5.1 allows local users to overwrite arbitrary files via a symlink attack on the NET::Telnet connecti"}