{"action":"Upgrade horizon to 2012.1-3 or later.","affected":[{"fixed":"2012.1-3","introduced":"0"}],"component":"horizon","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2012.1-3"],"id":"tcs_01M5NA0W15DYN5GCF6N8N5FNP7","modified_at":"2026-10-23T17:47:36.455113439Z","published_at":"2012-06-05T22:55:11.153Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2012-2094","https://security-tracker.debian.org/tracker/CVE-2012-2094"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2012-2094#Debian:14/horizon","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2012-2094"}],"summary":"Cross-site scripting (XSS) vulnerability in the refresh mechanism in the log viewer in horizon/static/horizon/js/horizon.js in OpenStack Dashboard (Horizon) folsom-1 and 2012.1 and earlier allows remo"}