{"action":"Upgrade openssl to 1.0.1a-1 or later.","affected":[{"fixed":"1.0.1a-1","introduced":"0"}],"component":"openssl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["1.0.1a-1"],"id":"tcs_01M5NA0ZBDPN8JBFFYB0QKRC6C","modified_at":"2026-10-23T17:47:39.616236008Z","published_at":"2012-04-19T17:55:01.253Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2012-2110","https://security-tracker.debian.org/tracker/CVE-2012-2110"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2012-2110#Debian:13/openssl","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2012-2110"}],"summary":"The asn1_d2i_read_bio function in crypto/asn1/a_d2i_fp.c in OpenSSL before 0.9.8v, 1.0.0 before 1.0.0i, and 1.0.1 before 1.0.1a does not properly interpret integer data, which allows remote attackers"}