{"action":"Upgrade rubygems to 1.8.24-1 or later.","affected":[{"fixed":"1.8.24-1","introduced":"0"}],"component":"rubygems","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.8.24-1"],"id":"tcs_01M5NA11RDBDB3XEBWGV1KQ5FM","modified_at":"2026-10-23T17:47:47.249670229Z","published_at":"2013-10-01T17:55:03.257Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2012-2125","https://security-tracker.debian.org/tracker/CVE-2012-2125"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2012-2125","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2012-2125"}],"summary":"RubyGems before 1.8.23 can redirect HTTPS connections to HTTP, which makes it easier for remote attackers to observe or modify a gem during installation via a man-in-the-middle attack."}