{"action":"Upgrade ruby-mail to 2.4.4-1 or later.","affected":[{"fixed":"2.4.4-1","introduced":"0"}],"component":"ruby-mail","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.4.4-1"],"id":"tcs_01M5NA14MMHT3YPX7M21MAJ3KD","modified_at":"2026-10-23T17:47:34.158444482Z","published_at":"2012-07-18T18:55:01.510Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2012-2140","https://security-tracker.debian.org/tracker/CVE-2012-2140"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2012-2140#Debian:13/ruby-mail","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2012-2140"}],"summary":"The Mail gem before 2.4.3 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in a (1) sendmail or (2) exim delivery."}