{"action":"Upgrade nodejs to 0.6.17~dfsg1-1 or later.","affected":[{"fixed":"0.6.17~dfsg1-1","introduced":"0"}],"component":"nodejs","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.6.17~dfsg1-1"],"id":"tcs_01M5NA1DHT2YSQWRMVS8482V25","modified_at":"2026-10-23T17:47:51.183229474Z","published_at":"2012-08-13T23:55:01.130Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2012-2330","https://security-tracker.debian.org/tracker/CVE-2012-2330"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2012-2330#Debian:14/nodejs","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2012-2330"}],"summary":"The Update method in src/node_http_parser.cc in Node.js before 0.6.17 and 0.7 before 0.7.8 does not properly check the length of a string, which allows remote attackers to obtain sensitive information"}