{"action":"Upgrade strongswan to 4.5.2-1.4 or later.","affected":[{"fixed":"4.5.2-1.4","introduced":"0"}],"component":"strongswan","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["4.5.2-1.4"],"id":"tcs_01M5NA1JNHRJTY3TXRXTY15WRZ","modified_at":"2026-10-23T17:47:25.195021383Z","published_at":"2012-06-27T21:55:02.610Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2012-2388","https://security-tracker.debian.org/tracker/CVE-2012-2388"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2012-2388#Debian:14/strongswan","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2012-2388"}],"summary":"The GMP Plugin in strongSwan 4.2.0 through 4.6.3 allows remote attackers to bypass authentication via a (1) empty or (2) zeroed RSA signature, aka \"RSA signature verification vulnerability.\""}