{"action":"Upgrade nut to 2.6.4-1 or later.","affected":[{"fixed":"2.6.4-1","introduced":"0"}],"component":"nut","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.6.4-1"],"id":"tcs_01M5NA2GQSBN3BCRR6Z8ZR21GT","modified_at":"2026-10-23T17:47:24.478029752Z","published_at":"2012-06-01T20:55:08.857Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2012-2944","https://security-tracker.debian.org/tracker/CVE-2012-2944"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2012-2944#Debian:14/nut","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2012-2944"}],"summary":"Buffer overflow in the addchar function in common/parseconf.c in upsd in Network UPS Tools (NUT) before 2.6.4 allows remote attackers to execute arbitrary code or cause a denial of service (electric-p"}